PDA

View Full Version : Instalare aplicatii care necesita iOS 4 pe iOS 3.1.3



asdf
05-02-2012, 08:02 PM
Stie cineva cum se pot instala aplicatii care necesita iOS 4/5 pe iOS 3.1.3 ? Exista ceva tweak in cydia sau se poate face ceva in sensul acesta ?

OXXO
05-02-2012, 08:15 PM
Nu cred ca exista asa ceva, problema este ca nu iOS-ul nu te lasa sa instalezi acele aplicatii (aici era foarte simplu, faceau un tweak care sa forteze iOS-ul sa faca asta) ci aplicatia in sine este creata sa nu accepte instalarea decat de la un anumit iOS in sus. Unul sustine ca a reusit prin metoda asta:

It is actually not all that hard to do. If you are on an older firmware and you have iFile try finding the apps ipa and editing the plist file to install on your firmware.

Go to where iTunes stores your IPAs for your Apps. Find the app, rename it App.zip (App being the name of the application), then unzip it. Open Payload. Find the Info.plist. (if you can't edit it, try putting the files on the iphone and editing the plist using iFile)
Edit the plist minimum OS version to be as low as your current firmware. (you might also need to edit some other OS number in the info.plist, just check out the entire thing first.)
Now go back to the payload folder and zip it up. change the name back to app.ipa.

You can now install this ipa using iFunBox or whatever way you like.

I had this problem before I upgraded from 4.2.1 to 5.0.1
I wanted to use My Xbox Live app, but they only let you use it on 4.3.
So I changed the info.plist and then it worked.

*Note iFile can edit Plists by default.

*Also some apps will not work after doing this, for example an app on 5.0 may be coded differently than on 4.0, thus it will not run as expected. In my situation I was getting a 4.0 app to work on a 4.0 OS, so this worked perfectly.

Poti sa incerci daca nu ai ce face :)

asdf
05-02-2012, 08:19 PM
problema e ca nu vreau o aplicatie creata special pentru iOS 4...Vreau doar o versiune mai veche a aplicatiei care mergea pe 3.1.3 iar in iTunes nu mai este(este doar ultima versiune care necesita iOS 4). Nu stii unde pot gasi si versiuni mai vechi ale aplicatiilor(si nu site-uri unde sunt aplicatii crack-uite pentru ca acolo nu sunt si aplicatiile FREE).

OXXO
05-02-2012, 08:20 PM
Cum se numeste aplicatia? Gasesti si aplicatii mai vechi (free) pe acele site-uri, eu am fost nevoit sa instalez facebook si messenger pe 3.1.3 si le-am gasit pe cele vechi pe acele site-uri.

asdf
05-02-2012, 08:25 PM
Capitals Quizzer, asta o vreau acum. Am mai gasit si eu dar asta nu reusesc nici cum :|.

PS: Chestia cu editatu am incercat-o insa la app asta nu este in plist ce zice acolo.

OXXO
05-02-2012, 08:35 PM
Am trimis mail la developer, poate ai noroc si imi trimit un IPA mai vechi. Iti dau de stire daca imi raspund la mail.

asdf
05-02-2012, 08:36 PM
multumesc mult !

golurisigoale
05-03-2012, 12:34 PM
Doar daca ai .IPA mai poti face ceva ....pentru ca daca dezvoltatorul aplicatii a sterso nu o mai gasesti

OXXO
05-03-2012, 05:10 PM
N-ai noroc din pacate

Hi there,

Thanks for your e-mail. Unfortunately Capitals Quizzer requires iOS 4.0 to play, and I'm afraid there is no way to install an older version. I recommend you update your device to at least 4.0 to play any game in the Quizzer series.

Thanks,

Ben Ward
Founder, Supergonk Ltd.